25 Replies Latest reply: Mar 10, 2013 10:33 PM by C Spire Kat RSS

Samsung Galaxy S3 data problems

Shining

I posted this on a different thread, but decided to place it here in the "devices section" where it probably has more bearing.

 

I had the Galaxy S3 but now I no longer have the Galaxy S3.

 

I live in Pearl River county but I was working in Laurel when I got the phone. It worked fine in Laurel and on my way home 3 days later. Once I arrived home, I had 3G service for about 10 minutes then nothing. There was not even a 1X indicator on my S3. I called CSPIRE and we went through some steps but nothing helped.

 

I had to go out of town the next day and I figured the device would at least work after I left my home area, however after I got on the road, the device would still not pick up data, even going down the Interstate. I stopped in Hattiesburg and kept switching the network mode from CDMA to 4G LTE. After about the 4th time, it picked up 4G. I downloaded a couple of apps ( to test) and it was blazing fast. I set the network mode back to CDMA and continued on my way.(since there were not a lot of 4G areas online after Hattiesburg) As soon as I left Hattiesburg, the data problem returned. No data or just 1X. I called CSPIRE and they said they would push a "data fix". While I was still on the phone with them, my 3G icon appeared.

 

The device worked well the remainder of the trip. (signal quality was not as good as my other devices) but it did the job. As soon as I returned home on Saturday, no data once again.

 

I called CSPIRE a bunch. We went through many steps. Nothing. I got the text Monday about the software update and immediately went to a store and they did it for me.

 

Went home and monitored it for about 36 hours. The 3G icon would come on and stay a while then go to 1X. However, even when the 3G icon was showing, I could not access any data from my device while at home.

 

I took the S3 back yesterday and cancelled my upgrade. I hope they eventually get it figured out. I loved the phone and its features, but I refuse to pay the extra money and not be able to use data on it. Thankfully I had wifi here at the house while I was trying it out.

 

I really believe the issue is device specific. I have a milestone X, Galaxy S1 and Galaxy S2 all working fine on the 3G service here at my house. None of them have shown the same issue.

 

Whether it is something to do with towers not being upgraded or an internal firmware conflict within the device I do not know. Common sense tells me that if 3 other devices work fine on the network from my house, the other should be able to duplicate that experience as well.

 

Sure wish I had my Galaxy S3 back. (Working the way it should of course)